Printed Circuit Board Assembly & PCB Design SMT Electronics Assembly Manufacturing Forum

Printed Circuit Board Assembly & PCB Design Forum

SMT electronics assembly manufacturing forum.

Mydata TP-11 Small X not working

Views: 5639


Mydata TP-11 Small X not working | 25 March, 2009

The small x motor quit working.It seems that there is no voltage going to the motor.

Here is what I have done so far: *Verified that the motor is good. *Check pico fuses on the backplane *Verify voltages on backplane and on big booster. *Swap mot cards *Swap XWB *Swap big booster *Replace big blue ribbon cables *Uplugged all connectors from the computer box except for XXW2B.Also unplugged all MOT cards except for MOTX.(I was trying to determine if something else was sucking voltage)

I am !

reply »


Mydata TP-11 Small X not working | 26 March, 2009

Hi Sr. First suggestion is to call Mydata's phone support. With that said... Here is some ideas of what you could check:

1. Do you have power at the XWB board connector going to the motor (xxwm connector)?

2. Do you have power coming through the blue ribbon cable? (you would have to check schematic for XWB to see which cable carries the load).

3. You said you verified the motor is good? How?

reply »


Mydata TP-11 Small X not working | 26 March, 2009

I talked to Mydata service (briefly) 3 times. Halfway through the 3rd call it was suggested to me that we set up a service call. Times being what they are, we are not willing to go that route yet. Thankfully we are not in dire need of this machine right now.

I am assuming that there is no power to the connector on the XWB. When I take a known good motor and plug it into the XWB I do not get a response when I am telling it to pulse in the service prog. The above method is actually how I verified that my motor was good. I took the motor over to my other TP and plugged it into the XWB and pulsed it in the service program.It does what it is supposed to.

I have not measured the power at the blue cable.Thats my next move. If there is no power there then it has to be the ribbon cables coming from the computer box or something is wrong with the backplane.

Oh, one other thing. I did find 2 blown pico fuses on the backplane. I thought that was odd. Replacing them did not fix the issue.

Thank you.

reply »


Mydata TP-11 Small X not working | 31 March, 2009

Does the PIAB or ELMO have anything to do with the small X ?

I don't see any connection in the schematics.

reply »


Mydata TP-11 Small X not working | 31 March, 2009

Hey Avalancher, you dont by any chance work for Mydata do you ?

reply »



Mydata TP-11 Small X not working | 31 March, 2009

Take a look at the BM3 Ed-1C, page 6 schematic - lower middle. N17-N18 off of XXW2B goes to FX. Have you checked this fuse?

Good luck

reply »


Mydata TP-11 Small X not working | 1 April, 2009

Ya thats one of the first things I checked. AMK.

Thanks for takin a look.

reply »


Mydata TP-11 Small X not working | 15 April, 2009

I'm not sure if you fixed your problem yet or not but i'll give you some insight on your problem. The x wagon motor doesn't move cause of the voltage it actually moves when there's current applied to it. The voltage dictates the direction the motor moves positive is left to right and negative is right to left if i am remembering correctly. The current that drives the x wagon comes off the booster. So your problem is most likely that your booster needs to be replaced or you are losing the current along the way to the motor. But since you already changed your blue ribbon cables i would lean to the booster being bad. Hope this helps you out.

reply »


Mydata TP-11 Small X not working | 15 April, 2009

The booster was swapped.

I found that I have -35 volts across pins 1 and 3 on the XWB.(measured with a scope) When I switch polarity in the software I do not get anything.(no +35V) I noticed that when I try to pulse the small X with the scope hooked up the monitors flicker on and off. If I leave the scope hooked up and put the machine in powerdown sequence the motor turns on. Its like I have a faulty ground or something. I think its using the scope for ground.

I have e-mailed the good folks at Mydata service (a week ago) that would most likely be able to tell me whats wrong but I have not heard from them.

reply »


Mydata TP-11 Small X not working | 16 April, 2009

well by the looks of it you have pretty much replaced just about everything that could cause the problem. The only one i haven't seen is the cable going from the computer box up to the x-wagon boards. Just out of curiosity when you took your motor from another machine, I am assuming you plugged it in and held it in your hand and pulsed it through the service -x program. Maybe you forgot to load the mot boards before you did this which would make even a good motor not work. Taking a suspect motor and doing the same on another machine and pulsing it in your hand is not always reliable cause the motor may work unloaded but fail loaded.

reply »


Mydata TP-11 Small X not working | 20 April, 2009

I actually did replace the cable from the comp box to the X-boards.

The original small x-motor was indeed bad. I verified this by taking it to my working machine and trying to pulse it when it was in my hand. (the mot boards were loaded).

Then I took one of my spare used motors and verified that it worked by taking it to the good machine. I held it in my hand and pulsed it.

I don't think it is a load condition because I do not get any response what so ever at the "bad machine" when I try to pulse a motor that pulses on the good machine. Hope that makes sense.

reply »


Mydata TP-11 Small X not working | 21 April, 2009

ok you verified that the motor was bad. So now i would go back and verify that your voltages are still good on the back of the computer box and on the booster board. If they all check out fine. I would take the mot x board from your working machine and put it into the non working machine and try it.If not try swapping the booster again then finally the xwb3 x wagon board from your good machine since you know for sure they definately work.I have gotten parts from mydata that didn't work out of the box then pulled my hair out trying to figure out what was wrong. The only other thing that i can think that may cause the problem is your servo program may have become corrupt. So you can try reloading the same version of servo program if all else fails. If you have an account set up you can download it from the mydata support website.

reply »


Mydata TP-11 Small X not working | 21 April, 2009

Ha ! well Bruce it looks like great minds think alike. I have already tried everything you just listed.

I really appreciate your input. Sounds like you know these machines well.

reply »

Led tester

Flexible pick & Place