Printed Circuit Board Assembly & PCB Design SMT Electronics Assembly Manufacturing Forum

Printed Circuit Board Assembly & PCB Design Forum

SMT electronics assembly manufacturing forum.


Mydata TP9-UFP problem - Can't reach toolbank

Views: 2465

#81276

Mydata TP9-UFP problem - Can't reach tool bank | 22 October, 2018

Hi,

We're having issues with our mydata tp9 pick'n place. It doesn't go all the way down on the tool, so it can't pick it up or install it. The fault code I get when trying to install tools is F-TLMN-18: Can't reach tool bank. Any ideas?

I've compared the parameter settings with the values shown in the "show transducers" menu for each corresponding position and they all seem to be correct, so its not that the Z-axis has "slipped" or something like that, also the machine works fine except for the "pick up tool" bit so it clearly knows where it's at. The Z-axis can reach the hight of the tool bank in other situations so there is nothing mechanical hindering it either..

Any help appreciated!

//Filip Blad, Electronic Design Lab Sweden AB

reply »

#81278

Mydata TP9-UFP problem - Can't reach tool bank | 22 October, 2018

To narrow down the cause. Have you test it on all your tools? If only particular tool(s) having issue, then it might be tool that's having the problem.

reply »

#81279

Mydata TP9-UFP problem - Can't reach tool bank | 23 October, 2018

Yes, for all tools... The tool head stops just above the tool

reply »

#81281

Mydata TP9-UFP problem - Can't reach tool bank | 23 October, 2018

It is probably one of the Z lock solenoids not working properly. These are located along the Z axis and as part of the initiation of the machine, the Z measure the travel. Check the upper and lower Z locks

reply »

#81285

Mydata TP9-UFP problem - Can't reach tool bank | 24 October, 2018

I've checked the locks in the service program and the solenoids move when told to.. also I can see them opening when going to pick up a tool..

reply »

#81286

Mydata TP9-UFP problem - Can't reach tool bank | 24 October, 2018

Here is a video clip of the issue: https://photos.app.goo.gl/zGfXiPYAhfKFYmN96

and in this clip you can see the solenoids opening if you look closely: https://photos.app.goo.gl/j9ozSVkuNBT2Mxq36

reply »

#81293

Mydata TP9-UFP problem - Can't reach tool bank | 24 October, 2018

when the machine initiates the last move it does is in the Z axis. If memory serves me, during the last Z move it drives down and measures the stroke, if the lower solenoid is not fully retracted the axis measures the wrong travel limits. Hopefully that makes sense

reply »

#81294

Mydata TP9-UFP problem - Can't reach tool bank | 24 October, 2018

You mean that the problem could be that the solenoid retracts but not all the way?

reply »

#81295

Mydata TP9-UFP problem - Can't reach tool bank | 24 October, 2018

The solenoids seem to work properly and there are no problems when initiating the Z-axis

reply »

#81296

Mydata TP9-UFP problem - Can't reach tool bank | 24 October, 2018

Correct, if the Z comes into contact on it's downward stroke during init this can cause the problem you are seeing

reply »

#81297

Mydata TP9-UFP problem - Can't reach tool bank | 24 October, 2018

It could be the indicators inside the Z head, have you tried cleaning them? Can you post an image of the error that appears on the monitor?

reply »

#81298

Mydata TP9-UFP problem - Can't reach tool bank | 24 October, 2018

Picture of error in the link: https://photos.app.goo.gl/ptHcVwmbUi2Yi54z6

We did have a problem with the force sensor earlier, one of the cables was broken so I soldered it back together and now it works (I get a value of 180 when tool is inserted and then it goes down to about 20 when the spring is pressed), however, the issue that we have now doesn't seem to be connected to the first one ( I could be wrong). it started at random while I was fault finding the first problem, also, the tool head never goes down far enough to use the force sensor and if I insert the tools manually I can still use the machine for mounting boards

reply »

#81299

Mydata TP9-UFP problem - Can't reach tool bank | 24 October, 2018

That error points to a hardware issue. When it fails does it ask you to insert a tool manually?

reply »

Dual Lane Reflow Oven

Flexible pick & Place