Printed Circuit Board Assembly & PCB Design SMT Electronics Assembly Manufacturing Forum

Printed Circuit Board Assembly & PCB Design Forum

SMT electronics assembly manufacturing forum.

Servo alarm X2-axis (FIP-3)

Views: 3361


Servo alarm X2-axis (FIP-3) | 10 October, 2005

Hello to all!

Our Fuji FIP-3 placement machine has come up with a servo alarm (X2-axis) whenever we try to run the machine. The manuals don't go into a lot of detail as to the cause of this problem, but there is plenty of information on what the X2 axis does.

We've replaced the servo motor but no luck. Also there is no alarm indication on the servo pack itself inside the front access panels. Interestingly enough when you take it out of a pick and place program and do simple nozzle changes, the head (number 2) will change the nozzle and scan it over the camera for correct size without any problems. This head will zero-set without any problems at all as well.

Try to run a program and the IP3 will stop immediately with the X2 axis alarm. At present we're operating only on head 1 which means a lot of work changing programs over and not having enough feeder positions available. Any ideas?

Thanks :)

reply »



Servo alarm X2-axis (FIP-3) | 10 October, 2005

Dave, it could be that you have some dirt or grease on the linear scale for the X-axis. Try getting into the rubber shield with a soft brush or perhaps a spray. Threebond Super Cleaner 6602 is very good for this purpose as it cleans and dries without leaving a residue. There are details of how to clean the scale in the IP-3 maintenance manual.

Hope this fixes your problem.

Cheers, Alan.

reply »


Servo alarm X2-axis (FIP-3) | 11 October, 2005

-Are you running a program that worked before or is it a new program? -Is there any reason to suspect that the proper has been edited between working and error condition?


reply »



Servo alarm X2-axis (FIP-3) | 11 October, 2005

Hi Jerry,

I thought the same so tried running other programs that are known to work on the IP-3 but still no joy. I shall try Alan's suggestion with cleaning the linear scale and see what happens.


reply »


Servo alarm X2-axis (FIP-3) | 11 October, 2005

Does it do nozzle changes at a different speed than the programs? It's been a while since I worked on these beasts. I"m wondering if it can handle slow speeds but at full bore it can't handle it. Maybe try one part with everything set to slow speed in the part data. If that is it, then check the lead screws and guide rails and make sure everything is perfectly clean and lubed.

reply »



Servo alarm X2-axis (FIP-3) | 11 October, 2005

Hi Stephen!

The nozzle change happens at a much slower speed to what it runs at during pick and place. They are a great machine...when everything works on them ;-)

I tried sending through the proper data again and rebooted the machine. A interesting thing happened. After rebooting the machine a Y-axis servo alarm appeared and after rebooting the machine again and performing a zero-set, a calibration error occured ('LLL sensor zero readback error') code #12036020. The machine cannot be used at all as it will not zero set.

This apparently relates back to the movement of the z-traverse with the pick and place head, along with the q rotation. Having a look at the servo card responsible for this showed the green status LED to be off when all the other servo card LEDs were on. We removed one of the other identical servo cards, rearranged the DIP switches and swapped them over. The original card still had the status LED off, whereas the swapped card was functioning in the slot.

From this it appears that the servo card is the culpirit. I have a concern though that all servo cards (prior to sending the proper data through) all had the green status LED lit, and now they don't. Will let you know what happens when the replacement card from one of our other branches is installed into our machine here (hopefully tomorrow).

reply »


Servo alarm X2-axis (FIP-3) | 12 October, 2005

Hi all!

Well installing the servo card has fixed the status LED issue....however there is a new problem :(

When a production program is executed at the IP3 (pressing AUTO or START) the machine says 'communicating with the VP' (which is normal). When it tries to communicate with the MTU we get a error code 11082010 (which I believe is a transmission problem of proper data to the MTU) Have done a couple of reset starts, sending status, proper data and then a production progam but no success.

The host computer (an MCS-16) has MTU4 proper data installed on it, but there is no option for selecting the MTU when wanting to send proper data from the MCS; you can only select the IP3 (or whatever machine may be connected).

Time for a stiff drink!

reply »



Servo alarm X2-axis (FIP-3) | 13 October, 2005

If there is no option to send the proper data to the MTU it sounds like your line editor is configured incorrectly. You will still be able to send programs and the such but like you said you would never notice it until you had to send the proper back to the MTU. I would try editing the line editor and see if the MTU is installed for the IP3. It should share the same port and once installed you should be able to send the proper to the MTU using the IP3's port.

reply »

On-board Dispensing of Dots & Lines

pcb components vacuum pick up