Electronics Forum: broken (Page 1 of 36)

broken boards

Electronics Forum | Wed Jul 24 10:12:48 EDT 2002 | jax

Claude, Are you saying this is how ya'll handle the issue???

broken components

Electronics Forum | Wed May 27 04:45:48 EDT 2009 | mun4o

all components ar on the top side... regards

broken components

Electronics Forum | Wed May 27 08:03:39 EDT 2009 | davef

Please describe the break in the components. Attaching pictures would be helpful.

broken components

Electronics Forum | Fri May 29 08:22:09 EDT 2009 | scottp

It would help to see pictures, but I suspect the parts are seeing excessive strain when snapped into or removed from the pallet.

broken components

Electronics Forum | Tue May 26 10:23:53 EDT 2009 | mun4o

hi, i am proccess eng solder wave process.I have problem with a PCB.There have ceramic SMD capacitor, SMD thermistor and SMD inductor 1uH.After reflow all is OK, but after SW these components are broken???The pin is separated from the body???the que

broken boards

Electronics Forum | Wed Jul 24 07:18:12 EDT 2002 | lloyd

Hi, We occasionaly have problems with some of our panellised boards breaking away from each other. The section joining them is very small and makes the assembly weak. The boards are normally broken off during our through hole process (bad handling)

broken boards

Electronics Forum | Wed Jul 24 10:00:40 EDT 2002 | Claude_Couture

Hi Lloyd! You mention "bad handling" as the cause of the PCB breakage... One way to convince operators to be careful in handling PCBs is to make them pay for the broken ones! If the fault is theirs, they should pay for it. If it's not their fault, fi

broken boards

Electronics Forum | Wed Jul 24 16:36:53 EDT 2002 | russ

If you have a board router then I would reccomend an epoxy to re-attach the boards. If not try a high temp loctite russ

broken components

Electronics Forum | Wed May 27 07:02:34 EDT 2009 | xinxi

Have you tried profiling the board with temperature label or profiler thru wave? I reckon your pre-heat temperature might be too high either on top or bottom and cause the component to expand unevenly. Regards, xinxi

broken components

Electronics Forum | Fri May 29 02:02:07 EDT 2009 | cobar

The problem could be that the preheat temp of the PCB is too low on entering the bath.Also look at moisture ingression of components.Have a look at solder Assit at http://www.shanelo.co.za

  1 2 3 4 5 6 7 8 9 10 Next

broken searches for Companies, Equipment, Machines, Suppliers & Information